Em resumo
- CVE-2018-3725 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta hekto (hekto project), hekto.
- Chance de exploração nos próximos 30 dias (EPSS): 2.0%, maior que 80.9% das vulnerabilidades.
- Correção: atualize para 0.2.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| hekto | = 0.2.0
| No fix yet |
| hekto npm | < 0.2.3
| 0.2.3
|
Description
Versions of hekto before 0.2.3 are vulnerable to path traversal. This allows a remote attacker to read content of arbitrary files.
Recommendation
Update to version 0.2.3 or later.
NVD description
hekto node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free