Em resumo
- CVE-2018-3731 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta public.js (public.js project), public.
- Chance de exploração nos próximos 30 dias (EPSS): 2.0%, maior que 80.9% das vulnerabilidades.
- Correção: atualize para 0.1.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| public.js | = 0.1.2
| No fix yet |
| public npm | < 0.1.3
| 0.1.3
|
Description
Versions of public before 0.1.3 are vulnerable to path traversal. This is due to lack of file path sanitization which could lead to any file the parent process has access to on the server to be read by malicious user.
Recommendation
Update to version 0.1.3 or later.
NVD description
public node module suffers from a Path Traversal vulnerability due to lack of validation of filePath, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free