Em resumo
- CVE-2018-3745 é uma vulnerabilidade CRÍTICO (CVSS 9.1) que afeta atob (atob project), atob.
- Chance de exploração nos próximos 30 dias (EPSS): 2.1%, maior que 82.0% das vulnerabilidades.
- Correção: atualize para 2.1.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| atob | ≤ 2.0.3
| No fix yet |
| atob npm | < 2.1.0
| 2.1.0
|
Description
Versions of atob before 2.1.0 uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Recommendation
Update to version 2.1.0 or later.
NVD description
atob 2.0.3 and earlier allocates uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free