Em resumo
- CVE-2018-3774 é uma vulnerabilidade CRÍTICO (CVSS 10.0) que afeta url-parse.
- Chance de exploração nos próximos 30 dias (EPSS): 3.8%, maior que 90.0% das vulnerabilidades.
- Correção: atualize para 1.4.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| url-parse npm | ≥ 1.0.0, < 1.4.3
| 1.4.3
|
Description
Versions of url-parse before 1.4.3 returns the wrong hostname which could lead to Open Redirect, Server Side Request Forgery (SSRF), or Bypass Authentication Protocol vulnerabilities.
Recommendation
Update to version 1.4.3 or later.
NVD description
Incorrect parsing in url-parse <1.4.3 returns wrong hostname which leads to multiple vulnerabilities such as SSRF, Open Redirect, Bypass Authentication Protocol.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free