Em resumo
- CVE-2019-0187 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta org.apache.jmeter:ApacheJMeter, jmeter (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 2.6%, maior que 85.6% das vulnerabilidades.
- Correção: atualize para 5.1 ou posterior.
Description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
NVD description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
Mais vulnerabilidades de org.apache.jmeter:ApacheJMeter
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free