Em resumo
- CVE-2019-16762 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta slpjs (simpleledger), slpjs.
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 65.7% das vulnerabilidades.
- Correção: atualize para 0.21.4 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| slpjs | < 0.21.4
| 0.21.4
|
| slpjs npm | < 0.21.4
| 0.21.4
|
Description
Validator parsing discrepancy due to string encoding
Impact
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus.
Patches
All versions > 0.21.3 are patched.
Workarounds
Upgrade to any version >= 0.21.4.
References
The bug was located and fixed here.
For more information
If you have any questions or comments about this advisory:
NVD description
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free