Em resumo
- CVE-2020-15242 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta next.js (vercel), next.
- Chance de exploração nos próximos 30 dias (EPSS): 0.77%, maior que 55.7% das vulnerabilidades.
- Correção: atualize para 9.5.4 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
| next npm | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
Description
NVD description
Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free