Em resumo
- CVE-2020-26223 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta spree_api, spree (spreecommerce).
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 66.3% das vulnerabilidades.
- Correção: atualize para 3.7.13, 4.0.5, 4.1.12 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| spree_api RubyGems | ≥ 3.7.0, < 3.7.13≥ 4.0.0, < 4.0.5≥ 4.1.0, < 4.1.12
| 3.7.134.0.54.1.12
|
| spree | ≥ 3.7.0, < 3.7.13≥ 4.0.0, < 4.0.5≥ 4.1.0, < 4.1.12
| 3.7.134.0.54.1.12
|
Description
Impact
The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token
Patches
Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.
References
Pull request with a fix and in-depth explanation - https://github.com/spree/spree/pull/10573
For more information
If you have any questions or comments about this advisory:
NVD description
Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free