Em resumo
- CVE-2020-26296 é uma vulnerabilidade ALTO (CVSS 8.7) que afeta vega (vega project), vega.
- Chance de exploração nos próximos 30 dias (EPSS): 1.7%, maior que 77.4% das vulnerabilidades.
- Correção: atualize para 5.17.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| vega | < 5.17.3
| 5.17.3
|
| vega npm | < 5.17.3
| 5.17.3
|
Description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package.
In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could
execute arbitrary javascript on a victim's machine.
This is fixed in version 5.17.3
NVD description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free