Em resumo
- CVE-2021-21408 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta smarty/smarty, smarty (smarty).
- Chance de exploração nos próximos 30 dias (EPSS): 2.1%, maior que 81.5% das vulnerabilidades.
- Correção: atualize para 4.0.3, 3.1.43 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.0.3< 3.1.43
| 4.0.33.1.43
|
| smarty | ≥ 4.0.0, < 4.0.3< 3.1.43
| 4.0.33.1.43
|
Description
Impact
Template authors could run restricted static php methods.
Patches
Please upgrade to 3.1.40 or higher.
References
See the documentation on Smarty security features on the static_classes access filter.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
NVD description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free