Em resumo
- CVE-2021-23840 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta epolicy orchestrator (mcafee), node.js (nodejs), openssl (openssl).
- Chance de exploração nos próximos 30 dias (EPSS): 50.7%, maior que 98.9% das vulnerabilidades.
- Correção: atualize para 5.10.0, 10.24.0, 12.21.0, 15.10.0 ou posterior.
Description
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
Mais vulnerabilidades de epolicy orchestrator
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free