Em resumo
- CVE-2021-27291 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta pygments, pygments (pygments).
- Chance de exploração nos próximos 30 dias (EPSS): 3.9%, maior que 90.3% das vulnerabilidades.
- Correção: atualize para 2.7.4 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pygments PyPI | ≥ 1.1, < 2.7.4
| 2.7.4
|
| pygments | ≥ 1.1, < 2.7.4
| 2.7.4
|
Description
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
NVD description
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free