Em resumo
- CVE-2021-32699 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta github.com/pterodactyl/wings, wings (pterodactyl).
- Chance de exploração nos próximos 30 dias (EPSS): 0.27%, maior que 18.5% das vulnerabilidades.
- Correção: atualize para 1.4.4 ou posterior.
Description
Impact
All versions of Pterodactyl Wings preior to 1.4.4 are vulnerable to system resource exhaustion due to improper container process limits being defined. A malicious user can consume more resources than intended and cause downstream impacts to other clients on the same hardware, eventually causing the physical server to stop responding.
Patches
Users should upgrade to 1.4.4.
Workarounds
There is no non-code based workaround for impacted versions of the software. Users running customized versions of this software can manually set a PID limit for containers created.
For more information
If you have any questions or comments about this advisory:
- Contact us on Discord
- Email us at
dane ät pterodactyl dot io
NVD description
Wings is the control plane software for the open source Pterodactyl game management system. All versions of Pterodactyl Wings prior to `1.4.4` are vulnerable to system resource exhaustion due to improper container process limits being defined. A malicious user can consume more resources than intended and cause downstream impacts to other clients on the same hardware, eventually causing the physical server to stop responding. Users should upgrade to `1.4.4` to mitigate the issue. There is no non-code based workaround for impacted versions of the software. Users running customized versions of this software can manually set a PID limit for containers created.
Mais vulnerabilidades de github.com/pterodactyl/wings
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free