| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.kafka:kafka-clients | ≥ 2.0.0, < 2.6.3≥ 2.7.0, < 2.7.2≥ 2.8.0, < 2.8.1 | 2.6.32.7.22.8.1 |
| org.apache.kafka:kafka_2.11 | ≥ 2.0.0, ≤ 2.4.1 | |
| org.apache.kafka:kafka_2.12 | ≥ 2.0.0, < 2.6.3≥ 2.7.0, < 2.7.2≥ 2.8.0, < 2.8.1 | 2.6.32.7.22.8.1 |
| org.apache.kafka:kafka_2.13 | ≥ 2.4.0, < 2.6.3≥ 2.7.0, < 2.7.2≥ 2.8.0, < 2.8.1 | 2.6.32.7.22.8.1 |
| kafka | = 2.8.0≥ 2.0.0, < 2.6.3≥ 2.7.0, < 2.7.2 | 2.6.32.7.2 |
| communications brm - elastic charging engine | = 12.0.0.5.0< 12.0.0.4.6 | 12.0.0.4.6 |
| communications cloud native core policy | = 1.15.0 | |
| financial services analytical applications infrastructure | ≥ 8.0.6.0, ≤ 8.0.9.0≥ 8.1.0.0.0, ≤ 8.1.20 | |
| financial services behavior detection platform | = 8.1.1.0= 8.1.1.1= 8.1.2.0≥ 8.0.6.0.0, ≤ 8.0.8.0 | |
| financial services enterprise case management | = 8.0.7.1= 8.0.7.2= 8.0.8.0= 8.0.8.1= 8.1.1.0= 8.1.1.1 | |
| primavera unifier | = 18.8= 19.12= 20.12= 21.12 | |
| quarkus | < 2.2.4 | 2.2.4 |
Some components in Apache Kafka use Arrays.equals to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free