Em resumo
- CVE-2021-40111 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta org.apache.james:james-server, james (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 2.2%, maior que 82.5% das vulnerabilidades.
- Correção: atualize para 3.6.1 ou posterior.
Description
In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.
NVD description
In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.
Mais vulnerabilidades de org.apache.james:james-server
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free