Em resumo
- CVE-2021-41269 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta com.cronutils:cron-utils, cron-utils (cron-utils project).
- Chance de exploração nos próximos 30 dias (EPSS): 4.3%, maior que 91.3% das vulnerabilidades.
- Correção: atualize para 9.1.6 ou posterior.
Description
Impact
A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected.
Patches
The issue was patched and a new version was released. Please upgrade to version 9.1.6.
Workarounds
There are no known workarounds up to this moment.
References
A description of the issue is provided in issue 461
For more information
If you have any questions or comments about this advisory:
Open an issue in the cron-utils Github repository
NVD description
cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. The issue was patched and a new version was released. Please upgrade to version 9.1.6. There are no known workarounds known.
Mais vulnerabilidades de com.cronutils:cron-utils
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free