Em resumo
- CVE-2022-21697 é uma vulnerabilidade ALTO (CVSS 7.1) que afeta jupyter-server-proxy, jupyter server proxy (jupyter).
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 65.6% das vulnerabilidades.
- Correção: atualize para 3.2.1 ou posterior.
Description
Impact
What kind of vulnerability is it? Server-Side Request Forgery ( SSRF )
Who is impacted? Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled.
A lack of input validation allowed authenticated clients to proxy requests to other hosts, bypassing the allowed_hosts check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity.
Patches
Has the problem been patched? What versions should users upgrade to?
Upgrade to 3.2.1, or apply the patch https://github.com/jupyterhub/jupyter-server-proxy/compare/v3.2.0...v3.2.1.patch
For more information
If you have any questions or comments about this advisory:
NVD description
Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.
Mais vulnerabilidades de jupyter-server-proxy
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free