Em resumo
- CVE-2022-21715 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta codeigniter4/framework, codeigniter (codeigniter).
- Chance de exploração nos próximos 30 dias (EPSS): 1.0%, maior que 62.9% das vulnerabilidades.
- Correção: atualize para 4.1.8 ou posterior.
Description
Impact
Cross-Site Scripting (XSS) vulnerability was found in API\ResponseTrait in Codeigniter4.
Attackers can do XSS attacks if you are using API\ResponseTrait.
Patches
Upgrade to v4.1.8 or later.
Workarounds
Do one of the following:
- Do not use
API\ResponseTrait nor ResourceController
- Disable Auto Route and Use Defined Routes Only
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A cross-site scripting (XSS) vulnerability was found in `API\ResponseTrait` in Codeigniter4 prior to version 4.1.8. Attackers can do XSS attacks if a potential victim is using `API\ResponseTrait`. Version 4.1.8 contains a patch for this vulnerability. There are two potential workarounds available. Users may avoid using `API\ResponseTrait` or `ResourceController` Users may also disable Auto Route and use defined routes only.
Mais vulnerabilidades de codeigniter4/framework
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free