| Package | Affected versions | Patched versions |
|---|---|---|
| libreswan | ≥ 4.2, < 4.6 | 4.6 |
Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state object exists. This is fixed in 4.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free