Em resumo
- CVE-2022-24711 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta codeigniter4/framework, codeigniter (codeigniter).
- Chance de exploração nos próximos 30 dias (EPSS): 1.2%, maior que 67.5% das vulnerabilidades.
- Correção: atualize para 4.1.9 ou posterior.
Description
Impact
This vulnerability allows attackers to execute CLI routes via HTTP request.
Patches
Upgrade to v4.1.9 or later.
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.
Mais vulnerabilidades de codeigniter4/framework
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free