Em resumo
- CVE-2022-31147 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta jquery validation (jqueryvalidation), jquery-validation.
- Chance de exploração nos próximos 30 dias (EPSS): 2.2%, maior que 82.9% das vulnerabilidades.
- Correção: atualize para 1.19.5 ou posterior.
Description
Summary
Incomplete fix of CVE-2021-43306: An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the jquery-validation npm package, when an attacker is able to supply arbitrary input to the url2 method.
NVD description
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Mais vulnerabilidades de jquery validation
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free