Em resumo
- CVE-2022-31158 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta packbackbooks/lti-1-3-php-library, lti 1.3 tool library (packback).
- Chance de exploração nos próximos 30 dias (EPSS): 0.86%, maior que 58.6% das vulnerabilidades.
- Correção: atualize para 5.0, 5.0.0 ou posterior.
Description
Impact
Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
NVD description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Mais vulnerabilidades de packbackbooks/lti-1-3-php-library
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free