Em resumo
- CVE-2022-37023 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta org.apache.geode:geode-core, geode (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.8%, maior que 78.3% das vulnerabilidades.
- Correção: atualize para 1.15.0 ou posterior.
Description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
NVD description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Mais vulnerabilidades de org.apache.geode:geode-core
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free