Em resumo
- CVE-2022-37865 é uma vulnerabilidade CRÍTICO (CVSS 9.1) que afeta org.apache.ivy:ivy, ivy (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 2.1%, maior que 82.1% das vulnerabilidades.
- Correção: atualize para 2.5.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.ivy:ivy Maven | ≥ 2.4.0, < 2.5.1
| 2.5.1
|
| ivy | ≥ 2.4.0, < 2.5.1
| 2.5.1
|
Description
With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used
pack200 or zip packaging.
For artifacts using the "zip", "jar" or "war" packaging Ivy prior to version 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on
the local fie system that the user executing Ivy has write access to.
Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy version 2.5.1.
NVD description
With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used pack200 or zip packaging. For artifacts using the "zip", "jar" or "war" packaging Ivy prior to 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on the local fie system that the user executing Ivy has write access to. Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy 2.5.1.
Mais vulnerabilidades de org.apache.ivy:ivy
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free