Em resumo
- CVE-2022-39383 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta github.com/oam-dev/kubevela, kubevela (linuxfoundation).
- Chance de exploração nos próximos 30 dias (EPSS): 0.42%, maior que 36.7% das vulnerabilidades.
- Correção: atualize para 1.6.1, 1.6.2, 1.5.8, 1.5.9 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/oam-dev/kubevela Go | ≥ 1.6.0, < 1.6.1≥ 1.6.0-alpha.1, < 1.6.2< 1.5.8< 1.5.9
| 1.6.11.6.21.5.81.5.9
|
| kubevela | ≥ 1.6.0, < 1.6.2< 1.5.9
| 1.6.21.5.9
|
Description
Impact
Users using the VelaUX APIServer could be affected by this vulnerability.
When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability.
This issue is patched in 1.5.9 and 1.6.2.
References
Fix by: #5000
For more information
If you have any questions or comments about this advisory:
NVD description
KubeVela is an open source application delivery platform. Users using the VelaUX APIServer could be affected by this vulnerability. When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability. Users who're using v1.6, please update the v1.6.1. Users who're using v1.5, please update the v1.5.8. There are no known workarounds for this issue.
Mais vulnerabilidades de github.com/oam-dev/kubevela
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free