Em resumo
- CVE-2022-39396 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta parse-server (parseplatform), parse-server.
- Chance de exploração nos próximos 30 dias (EPSS): 38.7%, maior que 98.6% das vulnerabilidades.
- Correção: atualize para 5.3.1, 4.10.18 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 5.0.0, < 5.3.1< 4.10.18
| 5.3.14.10.18
|
| parse-server npm | ≥ 5.0.0, < 5.3.1< 4.10.18
| 5.3.14.10.18
|
Description
Impact
An attacker can use this prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser.
Patches
Prevent prototype pollution in MongoDB database adapter.
Workarounds
Disable remote code execution through the MongoDB BSON parser.
Collaborators
Mikhail Shcherbakov (KTH), Cristian-Alexandru Staicu (CISPA) and Musard Balliu (KTH) working with Trend Micro Zero Day Initiative
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.18, and prior to 5.3.1 on the 5.X branch, are vulnerable to Remote Code Execution via prototype pollution. An attacker can use this prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser. This issue is patched in version 5.3.1 and in 4.10.18. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free