Em resumo
- CVE-2022-41879 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta parse-server (parseplatform), parse-server.
- Chance de exploração nos próximos 30 dias (EPSS): 0.88%, maior que 59.1% das vulnerabilidades.
- Correção: atualize para 5.3.3, 4.10.20 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 5.0.0, < 5.3.3< 4.10.20
| 5.3.34.10.20
|
| parse-server npm | ≥ 5.0.0, < 5.3.3< 4.10.20
| 5.3.34.10.20
|
Description
Impact
A compromised Parse Server Cloud Code Webhook target endpoint allows an attacker to use prototype pollution to bypass the Parse Server requestKeywordDenylist option.
Patches
Improved keyword detection.
Workarounds
None.
Collaborators
Mikhail Shcherbakov, Cristian-Alexandru Staicu and Musard Balliu working with Trend Micro Zero Day Initiative
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 5.3.3 or 4.10.20, a compromised Parse Server Cloud Code Webhook target endpoint allows an attacker to use prototype pollution to bypass the Parse Server `requestKeywordDenylist` option. This issue has been patched in versions 5.3.3 and 4.10.20. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free