Em resumo
- CVE-2022-4891 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta sisimai, sisimai (libsisimai).
- Chance de exploração nos próximos 30 dias (EPSS): 1.4%, maior que 72.4% das vulnerabilidades.
- Correção: atualize para 4.25.14p12, 4.25.14 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| sisimai RubyGems | < 4.25.14p12
| 4.25.14p12
|
| sisimai | = 4.25.14< 4.25.14
| 4.25.14
|
Description
A vulnerability has been found in Sisimai up to 4.25.14p11 and classified as problematic. This vulnerability affects the function to_plain of the file lib/sisimai/string.rb. The manipulation leads to inefficient regular expression complexity. The exploit has been disclosed to the public and may be used. Upgrading to version 4.25.14p12 is able to address this issue. The name of the patch is 51fe2e6521c9c02b421b383943dc9e4bbbe65d4e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218452.
NVD description
A vulnerability has been found in Sisimai up to 4.25.14p11 and classified as problematic. This vulnerability affects the function to_plain of the file lib/sisimai/string.rb. The manipulation leads to inefficient regular expression complexity. The exploit has been disclosed to the public and may be used. Upgrading to version 4.25.14p12 is able to address this issue. The name of the patch is 51fe2e6521c9c02b421b383943dc9e4bbbe65d4e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218452.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free