Em resumo
- CVE-2023-0507 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta github.com/grafana/grafana, grafana (grafana).
- Chance de exploração nos próximos 30 dias (EPSS): 15.5%, maior que 96.8% das vulnerabilidades.
- Correção: atualize para 8.5.21, 9.2.13, 9.3.8 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/grafana/grafana Go | ≥ 8.1.0, < 8.5.21≥ 9.0.0, < 9.2.13≥ 9.3.0, < 9.3.8
| 8.5.219.2.139.3.8
|
| grafana | ≥ 8.1.0, < 8.5.21≥ 9.2.0, < 9.2.13≥ 9.3.0, < 9.3.8
| 8.5.219.2.139.3.8
|
Description
Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
NVD description
Grafana is an open-source platform for monitoring and observability.
Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap.
The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance.
An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript.
This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard.
Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
Mais vulnerabilidades de github.com/grafana/grafana
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free