Em resumo
- CVE-2023-22728 é uma vulnerabilidade MÉDIO (CVSS 4.3) que afeta silverstripe/framework, framework (silverstripe).
- Chance de exploração nos próximos 30 dias (EPSS): 0.49%, maior que 41.8% das vulnerabilidades.
- Correção: atualize para 4.12.5 ou posterior.
Description
The GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access.
Upgrade to silverstripe/framework 4.12.5 or above to address the issue.
Reported by Stephan Bauer from relaxt Webdienstleistungsagentur GmbH
NVD description
Silverstripe Framework is the Model-View-Controller framework that powers the Silverstripe content management system. Prior to version 4.12.15, the GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access. Users should upgrade to Silverstripe Framework 4.12.15 or above to address the issue.
Mais vulnerabilidades de silverstripe/framework
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free