Em resumo
- CVE-2023-22738 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta vantage6, vantage6 (vantage6).
- Chance de exploração nos próximos 30 dias (EPSS): 0.38%, maior que 31.5% das vulnerabilidades.
- Correção: atualize para 3.8.0rc3, 3.6.1, 3.8.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| vantage6 PyPI | ≥ 3.7.0, < 3.8.0rc3< 3.6.1< 3.8.0
| 3.8.0rc33.6.13.8.0
|
| vantage6 | = 3.8.0≥ 3.7.0, ≤ 3.7.3< 3.6.1
| 3.6.1
|
Description
Impact
Assigning existing users to a different organization is currently possible. It may lead to unintended access: if a user from organization A is accidentally assigned to organization B, they will retain their permissions and therefore might be able to access stuff they should not be allowed to access.
Patches
Update to 3.8.0
Workarounds
None
References
None
For more information
If you have any questions or comments about this advisory:
NVD description
vantage6 is a privacy preserving federated learning infrastructure for secure insight exchange. Assigning existing users to a different organizations is currently possible. It may lead to unintended access: if a user from organization A is accidentally assigned to organization B, they will retain their permissions and therefore might be able to access stuff they should not be allowed to access. This issue is patched in version 3.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free