Em resumo
- CVE-2023-23936 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta node.js (nodejs), undici (nodejs), undici.
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 66.4% das vulnerabilidades.
- Correção: atualize para 16.19.1, 18.14.1, 19.6.1, 5.19.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| node.js | ≥ 16.0.0, < 16.19.1≥ 18.0.0, < 18.14.1≥ 19.0.0, < 19.6.1
| 16.19.118.14.119.6.1
|
| undici | ≥ 2.0.0, < 5.19.1
| 5.19.1
|
| undici npm | ≥ 2.0.0, < 5.19.1
| 5.19.1
|
Description
Impact
undici library does not protect host HTTP header from CRLF injection vulnerabilities.
Patches
This issue was patched in Undici v5.19.1.
Workarounds
Sanitize the headers.host string before passing to undici.
References
Reported at https://hackerone.com/reports/1820955.
Credits
Thank you to Zhipeng Zhang (@timon8) for reporting this vulnerability.
NVD description
Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free