Em resumo
- CVE-2023-24807 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta undici (nodejs), undici.
- Chance de exploração nos próximos 30 dias (EPSS): 1.3%, maior que 70.7% das vulnerabilidades.
- Correção: atualize para 5.19.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| undici | < 5.19.1
| 5.19.1
|
| undici npm | < 5.19.1
| 5.19.1
|
Description
Impact
The Headers.set() and Headers.append() methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the headerValueNormalize() utility function.
Patches
This vulnerability was patched in v5.19.1.
Workarounds
There is no workaround. Please update to an unaffected version.
References
Credits
Carter Snook reported this vulnerability.
NVD description
Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the `Headers.set()` and `Headers.append()` methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the `headerValueNormalize()` utility function. This vulnerability was patched in v5.19.1. No known workarounds are available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free