Em resumo
- CVE-2023-26045 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta nodebb (nodebb), nodebb.
- Chance de exploração nos próximos 30 dias (EPSS): 1.0%, maior que 63.7% das vulnerabilidades.
- Correção: atualize para 2.8.7 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| nodebb | ≥ 2.5.0, < 2.8.7
| 2.8.7
|
| nodebb npm | ≥ 2.5.0, < 2.8.7
| 2.8.7
|
Description
Impact
Due to the use of the object destructuring assignment syntax in the user export code path, combined with a path traversal vulnerability, a specially crafted payload could invoke the user export logic to arbitrarily execute javascript files on the local disk.
Patches
Patched in v2.8.7
Workarounds
Site maintainers can cherry pick ec58700f6dff8e5b4af1544f6205ec362b593092 into their codebase to patch the exploit.
NVD description
NodeBB is Node.js based forum software. Starting in version 2.5.0 and prior to version 2.8.7, due to the use of the object destructuring assignment syntax in the user export code path, combined with a path traversal vulnerability, a specially crafted payload could invoke the user export logic to arbitrarily execute javascript files on the local disk. This issue is patched in version 2.8.7. As a workaround, site maintainers can cherry pick the fix into their codebase to patch the exploit.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free