Em resumo
- CVE-2023-3348 é uma vulnerabilidade MÉDIO (CVSS 5.7) que afeta wrangler (cloudflare), wrangler.
- Chance de exploração nos próximos 30 dias (EPSS): 0.82%, maior que 57.2% das vulnerabilidades.
- Correção: atualize para 3.1.1, 2.20.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| wrangler | < 3.1.1
| 3.1.1
|
| wrangler npm | < 2.20.1
| 2.20.1
|
Description
Impact
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Patches
Wrangler2: Upgrade to v2.20.1 or higher.
Wrangler3: Upgrade to v3.1.1 or higher.
References
Workers SDK on Github
Wrangler docs
CVE-2023-3348
NVD description
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free