Em resumo
- CVE-2023-35005 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta apache-airflow, airflow (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.5%, maior que 74.8% das vulnerabilidades.
- Correção: atualize para 2.6.2, 2.6.2rc1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.5.0, < 2.6.2≥ 2.5.0, < 2.6.2rc1
| 2.6.22.6.2rc1
|
| airflow | ≥ 2.5.0, < 2.6.2
| 2.6.2
|
Description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.
This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if [webserver] expose_config is set to non-sensitive-only), and not all uncensored values are actually sentitive.
This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
NVD description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.
This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive.
This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free