Em resumo
- CVE-2023-37379 é uma vulnerabilidade ALTO (CVSS 8.1) que afeta apache-airflow, airflow (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 2.0%, maior que 80.3% das vulnerabilidades.
- Correção: atualize para 2.7.0, 2.7.0b1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | < 2.7.0< 2.7.0b1
| 2.7.02.7.0b1
|
| airflow | < 2.7.0
| 2.7.0
|
Description
Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server.
Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.
NVD description
Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server.
Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free