Em resumo
- CVE-2023-46131 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta org.grails:grails-databinding, grails (grails).
- Chance de exploração nos próximos 30 dias (EPSS): 0.72%, maior que 54.1% das vulnerabilidades.
- Correção: atualize para 3.3.17, 4.1.3, 5.3.4, 6.1.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.grails:grails-databinding Maven | ≥ 2.0.0, < 3.3.17≥ 4.0.0, < 4.1.3≥ 5.0.0, < 5.3.4≥ 6.0.0, < 6.1.0
| 3.3.174.1.35.3.46.1.0
|
| grails | ≥ 4.0.0, < 4.1.3≥ 5.0.0, < 5.3.4≥ 6.0.0, < 6.1.0< 3.3.17
| 4.1.35.3.46.1.03.3.17
|
Description
Impact
A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable.
Patches
Patches are available for Grails 3 and later.
Workarounds
No workaround is possible except to avoid data binding to request data.
References
NVD description
Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.
Mais vulnerabilidades de org.grails:grails-databinding
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free