Em resumo
- CVE-2023-49920 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta apache-airflow, airflow (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.0%, maior que 63.8% das vulnerabilidades.
- Correção: atualize para 2.8.0, 2.8.0b1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.7.0, < 2.8.0≥ 2.7.0, < 2.8.0b1
| 2.8.02.8.0b1
|
| airflow | ≥ 2.7.0, ≤ 2.7.3
| No fix yet |
Description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent.
Users are advised to upgrade to version 2.8.0 or later which is not affected
NVD description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent.
Users are advised to upgrade to version 2.8.0 or later which is not affected
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free