Em resumo
- CVE-2024-12029 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta invokeai.
- Chance de exploração nos próximos 30 dias (EPSS): 6.0%, maior que 93.3% das vulnerabilidades.
- Correção: atualize para 5.4.3rc1, 5.4.3rc2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| invokeai PyPI | ≥ 5.3.1, < 5.4.3rc1≥ 5.3.1, < 5.4.3rc2
| 5.4.3rc15.4.3rc2
|
Description
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3rc2.
NVD description
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free