Em resumo
- CVE-2024-12678 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta github.com/hashicorp/nomad, nomad (hashicorp).
- Chance de exploração nos próximos 30 dias (EPSS): 0.53%, maior que 44.8% das vulnerabilidades.
- Correção: atualize para 1.9.4, 1.7.16, 1.8.8 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/nomad Go | < 1.9.4
| 1.9.4
|
| nomad | ≥ 1.4.0, < 1.7.16≥ 1.4.0, < 1.9.4≥ 1.8.0, < 1.8.8≥ 1.9.0, < 1.9.4
| 1.7.161.9.41.8.8
|
Description
Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.
NVD description
Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.
Mais vulnerabilidades de github.com/hashicorp/nomad
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free