Em resumo
- CVE-2024-2171 é uma vulnerabilidade MÉDIO (CVSS 4.8) que afeta zenml, zenml (zenml).
- Chance de exploração nos próximos 30 dias (EPSS): 0.37%, maior que 30.5% das vulnerabilidades.
- Correção: atualize para 0.56.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| zenml PyPI | < 0.56.2
| 0.56.2
|
| zenml | < 0.56.2
| 0.56.2
|
Description
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
NVD description
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free