Em resumo
- CVE-2024-24556 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta urql (nearform), @urql/next.
- Chance de exploração nos próximos 30 dias (EPSS): 0.36%, maior que 29.2% das vulnerabilidades.
- Correção: atualize para 1.1.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| urql | < 1.1.1
| 1.1.1
|
| @urql/next npm | < 1.1.1
| 1.1.1
|
Description
impact
The @urql/next package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns html tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream.
To fix this vulnerability upgrade to version 1.1.1
NVD description
urql is a GraphQL client that exposes a set of helpers for several frameworks. The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free