Em resumo
- CVE-2024-28190 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta contao/core-bundle, contao (contao).
- Chance de exploração nos próximos 30 dias (EPSS): 0.50%, maior que 43.0% das vulnerabilidades.
- Correção: atualize para 4.13.40, 5.3.4 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| contao/core-bundle Packagist | ≥ 4.0.0, < 4.13.40≥ 5.0.0-RC1, < 5.3.4
| 4.13.405.3.4
|
| contao | ≥ 4.0.0, < 4.13.40≥ 5.0.0, < 5.3.4
| 4.13.405.3.4
|
Description
Impact
Users can insert malicious code into file names when uploading files, which is then executed in tooltips and popups in the backend.
Patches
Update to Contao 4.13.40 or Contao 5.3.4.
Workarounds
Disable uploads for untrusted users.
References
https://contao.org/en/security-advisories/cross-site-scripting-in-the-file-manager
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Credits
Thanks to Alexander Wuttke for reporting this vulnerability.
NVD description
Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, remove upload fields from frontend forms and disable uploads for untrusted back end users.
Mais vulnerabilidades de contao/core-bundle
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free