Em resumo
- CVE-2024-31447 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta shopware/core, shopware/platform, shopware (shopware).
- Chance de exploração nos próximos 30 dias (EPSS): 0.50%, maior que 42.7% das vulnerabilidades.
- Correção: atualize para 6.5.8.8, 6.6.1.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| shopware/core Packagist | ≥ 6.3.5.0, < 6.5.8.8≥ 6.6.0.0-rc1, < 6.6.1.0
| 6.5.8.86.6.1.0
|
| shopware/platform Packagist | ≥ 6.3.5.0, < 6.5.8.8≥ 6.6.0.0-rc1, < 6.6.1.0
| 6.5.8.86.6.1.0
|
| shopware | ≥ 6.3.5.0, < 6.5.8.8≥ 6.6.0.0, < 6.6.1.0
| 6.5.8.86.6.1.0
|
Description
Impact
When a authentificated request is made to POST /store-api/account/logout, the cart will be cleared, but the User won't be logged out. This affects only the direct store-api usage, as the PHP Storefront listens additionally on CustomerLogoutEvent and invalidates the session additionally.
Patches
The problem has been fixed with Shopware 6.6.1.0 and 6.5.8.8.
Workarounds
When you are not able to update, you can install the latest version of the Shopware Security Plugin.
NVD description
Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Starting in version 6.3.5.0 and prior to versions 6.6.1.0 and 6.5.8.8, when a authenticated request is made to `POST /store-api/account/logout`, the cart will be cleared, but the User won't be logged out. This affects only the direct store-api usage, as the PHP Storefront listens additionally on `CustomerLogoutEvent` and invalidates the session additionally. The problem has been fixed in Shopware 6.6.1.0 and 6.5.8.8. Those who are unable to update can install the latest version of the Shopware Security Plugin as a workaround.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free