Em resumo
- CVE-2024-34350 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta next.js (vercel), next.
- Chance de exploração nos próximos 30 dias (EPSS): 1.2%, maior que 67.9% das vulnerabilidades.
- Correção: atualize para 13.5.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 13.4.0, < 13.5.1
| 13.5.1
|
| next npm | ≥ 13.4.0, < 13.5.1
| 13.5.1
|
Description
Impact
Inconsistent interpretation of a crafted HTTP request meant that requests are treated as both a single request, and two separate requests by Next.js, leading to desynchronized responses. This led to a response queue poisoning vulnerability in the affected Next.js versions.
For a request to be exploitable, the affected route also had to be making use of the rewrites feature in Next.js.
Patches
The vulnerability is resolved in Next.js 13.5.1 and newer. This includes Next.js 14.x.
Workarounds
There are no official workarounds for this vulnerability. We recommend that you upgrade to a safe version.
References
https://portswigger.net/web-security/request-smuggling/advanced/response-queue-poisoning
NVD description
Next.js is a React framework that can provide building blocks to create web applications. Prior to 13.5.1, an inconsistent interpretation of a crafted HTTP request meant that requests are treated as both a single request, and two separate requests by Next.js, leading to desynchronized responses. This led to a response queue poisoning vulnerability in the affected Next.js versions. For a request to be exploitable, the affected route also had to be making use of the [rewrites](https://nextjs.org/docs/app/api-reference/next-config-js/rewrites) feature in Next.js. The vulnerability is resolved in Next.js `13.5.1` and newer.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free