Em resumo
- CVE-2024-37389 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta org.apache.nifi:nifi-web-ui, nifi (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 24.0%, maior que 97.8% das vulnerabilidades.
- Correção: atualize para 1.27.0, 2.0.0-M4 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi-web-ui Maven | ≥ 1.10.0, < 1.27.0≥ 2.0.0-M1, < 2.0.0-M4
| 1.27.02.0.0-M4
|
| nifi | = 2.0.0≥ 1.10.0, < 1.27.0
| 1.27.0
|
Description
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
NVD description
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
Mais vulnerabilidades de org.apache.nifi:nifi-web-ui
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free