Em resumo
- CVE-2024-40761 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta github.com/apache/incubator-answer, answer (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.75%, maior que 54.9% das vulnerabilidades.
- Correção: atualize para 1.4.0 ou posterior.
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
NVD description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Mais vulnerabilidades de github.com/apache/incubator-answer
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free