Em resumo
- CVE-2024-45314 é uma vulnerabilidade MÉDIO (CVSS 5.5) que afeta flask-appbuilder, flask-appbuilder (dpgaspar).
- Chance de exploração nos próximos 30 dias (EPSS): 0.27%, maior que 18.4% das vulnerabilidades.
- Correção: atualize para 4.5.1 ou posterior.
Description
Impact
Auth DB login form default cache directives allows browser to locally store sensitive data. This can be an issue on environments using shared computer resources.
Patches
Upgrade flask-appbuilder to version 4.5.1
Workarounds
If upgrading is not possible configure your web server to send the following HTTP headers for /login:
"Cache-Control": "no-store, no-cache, must-revalidate, max-age=0"
"Pragma": "no-cache"
"Expires": "0"
NVD description
Flask-AppBuilder is an application development framework. Prior to version 4.5.1, the auth DB login form default cache directives allows browser to locally store sensitive data. This can be an issue on environments using shared computer resources. Version 4.5.1 contains a patch for this issue. If upgrading is not possible, configure one's web server to send the specific HTTP headers for `/login` per the directions provided in the GitHub Security Advisory.
Mais vulnerabilidades de flask-appbuilder
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free