Em resumo
- CVE-2024-45590 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta body-parser (openjsf), body-parser.
- Chance de exploração nos próximos 30 dias (EPSS): 0.82%, maior que 57.4% das vulnerabilidades.
- Correção: atualize para 1.20.3 ou posterior.
Description
Impact
body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service.
Patches
this issue is patched in 1.20.3
References
NVD description
body-parser is Node.js body parsing middleware. body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service. This issue is patched in 1.20.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free